HOWTO: Fix IE 9 issues in older versions of Sugar

bsoremsugar —  September 22, 2011 — 2 Comments

We released Sugar 6.2.2 a few weeks ago with support for IE 9. That’s great news if you are already on 6.2 or 6.2.1, but if for whatever reason you are stuck back in 6.1, 6.0, or ( gasp ) 5.5, here’s an easy way to gain IE 9 compatibility ( thanks to zucherli on the forums ).

Add a copy the file named themes/default/tpls/_head.tpl ( if on 5.5 ), themes/Sugar5/tpls/_head.tpl ( if on 6.x CE ), or themes/Sugar/tpls/_head.tpl ( if on 6.x PRO or later ) to the custom directory, and edit it to add the following line right after thetag:

Do a Quick Rebuild and Repair and you should be IE 9 friendly.

2 responses to HOWTO: Fix IE 9 issues in older versions of Sugar

  1. 

    Today I struggled over an 5.5.3 with IE9 for upgrading. Lot of things aren’t working there. I just turned on the compatiblity mode in the Tools menu and everything worked fine as expected.

  2. 

    but ,what should be added to that custom file ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s