PHP 5 Support Plan

sugarcrmdevelopers —  May 28, 2008 — Leave a comment

As you know, Sugar 5.1 will be our first release where we support only PHP 5 and will drop support for PHP 4. The minimum supported version of PHP for Sugar 5.1 will be PHP 5.1.

With PHP 5.2 now the primary release supported by the PHP team and no more work being done on PHP 5.1, we plan to drop support for PHP 5.1 and require a minimum version of PHP 5.2 with the Sugar 5.5 release targeted at the end of this year. We still support PHP 5.1, but do recommend that you use the latest version of PHP 5.2 as that is proving to be a far more stable PHP release for Sugar to run.

To summarize:

  • Sugar 5.0 requires a minimum of PHP 4.4.1, but we recommend PHP 5.2
  • Sugar 5.1 will require a minimum of PHP 5.1.0, but again we recommend PHP 5.2
  • With Sugar 5.5 at the end of the year, we will require a minimum of PHP 5.2

Onwards and upwards!

No Comments

Be the first to start the conversation!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s